Cannot read SD card with Mac computer


Hi, I cannot read formatted card with a Mac computer. I can read the file with Windows.


How can I solve the issue?

New Post (12)
  • 0 Quote 2Floor
    Hi there, same problem on Macbook air 2020 !!
    9 Months+
  • 70mai 8 Months+
    0 Quote 3Floor
    I didn't find this problem in my MacBook 2020 so far. Did you try another Type-C to TF adapter?
    8 Months+
  • 0 Quote 4Floor
    Hello everybody,
    I have that problem too. On the Mac, the 128GB Samsung EVO cannot be read on the Windows computer, but it can.
    I still have a 64GB EVO card, but it can be read on the MAC.
    Is there a solution?
    8 Months+
  • 70mai 8 Months+
    0 Quote 5Floor
    M-DRV_1619860217589 Hello everybody, I have that problem too. On the Mac, the 128GB Samsung EVO cannot be read on the W ...
    Can you tell me the firmware version of dash cam, the SN number, system version of your MacBook?

    You can send these info to me via private message.
    8 Months+
  • 70mai 8 Months+
    0 Quote 6Floor
    Btw, are you using MacBook Air or MacBook Pro?
    8 Months+
  • 0 Quote 7Floor
    I sent you a private message @70mai
    7 Months+
  • 0 Quote 8Floor
    I have the same problem on MacBook Pro macOS Big Sur 11.4
    6 Months+
  • receens2k 4 Months+
    0 Quote 9Floor

    same issue here with lates Firmware on the camera and my MacBook Pro macOS Big Sur 11.5.2. I tried three different card readers. No success :(

    I used the SD card you offer in your AliExpress Store.

    4 Months+
  • 1 Quote 10Floor
    In my case, both Mac and PC cannot read the a800s formatted card with all type of card reader even the firmware was updated.
    3 Months+
  • receens2k 3 Months+
    0 Quote 11Floor
    @70mai sent you a pn as requested by your sellingteam
    3 Months+
  • receens2k 3 Months+
    0 Quote 12Floor
    Update: tried serval SD cards (that have been working in my other cameras and devices) and tried mac os and windows. No success. As soon, as the a800s has formatted the cards, they cannot be read anymore in any computer. I think the formatting algorithm does not create the mbr and/or partition correctly.
    This is awkward.
    3 Months+
  • 0 Quote 13Floor
    I tried 256 card
    I have same problem on macbook 
    I try to format card to exfat - mai70 after inserting card wanted to format card two
    Than I format card to fat32 on macbook, after inserting mai70 want to format card and I agree: after formating on macbook, than on mai70 - a have card that mai70 can write and macbook can read
    5 Days+
Back
Create New Thread