Midrive RC05 abnormally connected Official Backup camera


1 week after installation backup camera freez out and its not working anymore.

error message: Backup Camera is connected abnormally, please re-plug

What i tried so far:

re-plug

reset full Dash Cam Wide

format memory card

at the backend re plug the camera to the cabel

Any sollution for this or i have to send it back?




New Post (11)
  • M-DRV_1602002129992 11 Months+
    1 Quote 2Floor
    I have the same problem and I replied with image but my post is being deleted by Moderator. 
    11 Months+
  • M-DRV_1602002129992 11 Months+
    0 Quote 3Floor

    Somebody pls help me. 
    I have bought new Rear View mirror wide and it shows "backup camera connected abnormally. Re plug it. I tried everything but it didn't work. I even plugged in my frind's rear cam from same model and it too can't work.


    My rear camera worked well in friend's rear view mirror device. 


    Pls help. Image is attached. Video is not allowed inspite size is just 6MB.

    上传的附件:
    11 Months+
  • Paweł Bukowski 11 Months+
    0 Quote 4Floor

    Same problem here... Tried on other rear camera and it still doesn't work :(

    It's my second 70mai Rearview Dash Cam Wide. The first one died totally after one day of usage and was replaced... the second one worked fine for about 2 months and this issue has occurred. The front camera still works.

    11 Months+
  • M-DRV_1570215667423 11 Months+
    0 Quote 5Floor
    I have the same problem with 70mai MiDrive RC05
    11 Months+
  • M-DRV_1570215667423 11 Months+
    0 Quote 6Floor
    Nothing help to solve this?
    11 Months+
  • M-DRV_1606017554155 10 Months+
    0 Quote 7Floor
    Same issue observed. Worked during 1st day and now getting the same error from backup camera. Dash cam is working. Is it due to compatibility issue ?
    Mirror : 70mai Rearview Dash Cam Wide, Model : Midrive D07
    Backup Camera: Midrive RC05
    10 Months+
  • 0 Quote 8Floor
    70mai will Never reply for any of your such After sales complaint. Price is Cheaper so the service is Cheapest.

    The only solution I found is to Replace the Main Unit i.e  Front Device.
    9 Months+
  • 0 Quote 9Floor
    a mi me pasa lo mismo el mismo dia que la instale ya no me funciono me pasa como a vosotros  me mandaron otra y nada sigo con el mismo problema 70 MAI REARVIEW DASH CAM WIDE MODELO MIDRIVE D07 y la camara trasera MIDRIVE RC05 
    5 Months+
  • ONorbert89 3 Months+
    0 Quote 10Floor
    Hi,
    I had the same problem, but I successfully fixed it. In my case, the cable connector slipped apart inside of the backup camera. So I screwed out the four little screws from the back of camera body and after that I pulled apart it. The back circuit didnt connect well to the other circuit. So I connected the two circuits and reassembled the body and it works again.
    3 Months+
  • 70mai 3 Months+
    1 Quote 11Floor
    ONorbert89 Hi, I had the same problem, but I successfully fixed it. In my case, the cable connector slipped ap ...
    Glad to hear that your device has been fixed by your own. As for those forum members who don't know how to fix this problem. I strongly recommend you guys to contact the seller for getting a replacement.

    This is definitely a hardware problem
    3 Months+
  • ciotta 14 Days+
    0 Quote 12Floor

    I have the same exact problem with my 1 week old "night vision backup camera". I've sent a replacemnt request at



    on Aliexpress.
    I hope youour comapny can send me a replacement.
    thankyou


    14 Days+
Back
Create New Thread