70mai Dash Cam M300 - Crashed and is OFF after updating firmware to 1.0.5ww! Please help


I tried pushing the latest firmware (1.0.5ww) to my M300 dashcam. Knowing that the power was not interrupted, the camera went down and it's not turning on!
Please any suggestions?

New Post (3)
  • Amicus 10 Days+
    0 Quote 2Floor

    You can try update from SD card.

    Turn off camera. Remove SD card and copy FW_DR1300.bin on SD card root.

    Insert SD card back ito the camera and turn it on.

    Wait until update is finished. Button will be blinking for two or three minutes.

    You can download file from HERE

    There is also PDF manual how to install firmware.

    I have received that file during testing of M300 dashCam.

    Good luck

    10 Days+
  • 0 Quote 3Floor
    Hello, thanks for your help. I tried what you said , but the camera is not up ( even the blue led is not turning on. What can I do ?
    5 Days+
  • Amicus 3 Days+
    0 Quote 4Floor
    How about power supply? Did you check if you have power? Connect some other USB device and check if it works on that cable.
    You can try to power camera with some other cable and power supply for laptop or mobile phone.
    3 Days+
Back
Create New Thread