lost all settings, device trying to calibrate ADAS at restart



I have installed a new 70mai Dash Cam A800s. The unit worked well for 1 day. After the initial setup I have installed a SD card, and connected the camera with the 70mai app on my android phone with the English language selected as the language for the user interface. After the first day, when the camera turns on, it is trying to calibrate the ADAS function (even though I have turned it off) and has switched to Mandarin language (even though the user interface was set to English). While it's trying to calibrate none of the buttons work with the exception of the power button. It has the wifi turned off, therefore I can't connect to it via the app to try to change the settings.

   Since the wifi is off and none of the menu buttons work I can't get it out of the calibration menu. I have tried to hard reset it by pressing the power button for 15 seconds (or 5 times, as stated in some forums), but it just keeps coming back to the calibration when I turn it on. As such the unit is useless.

    Is this a faulty device? How can I reset it to factory settings?


New Post (8)
  • 1 Quote 2Floor
    I have the same problem!
    Constantly calibrating and I can't access menu anymore.
    79mai what's going on ???
    2 Months+
  • 1 Quote 3Floor
    https://1drv.ms/v/s!Ag3lum91AuUwgoVw7BcI6XYaJ_dl8w?e=8gmHzK
    2 Months+
  • 0 Quote 4Floor
    The technical support of 70mai was very helpful. A firmware update has solved the problem. See here: https://drive.google.com/file/d/1FdBdrq1kbn4WrJn4UQWgE-mEf0F2j09j/view?usp=sharing
    2 Months+
  • 0 Quote 5Floor
    No, the problem is still there.
    Nothing is working, impossible to get to the MENU.

    HOW TO HARD RESET ????
    Where is technical support here????
    2 Months+
  • 0 Quote 6Floor
    M-DRV_1621343348812 The technical support of 70mai was very helpful. A firmware update has solved the problem. See here: ...
    ZERO SUPPORT !!! Solve this issue !!!
    2 Months+
  • Vakcina 2 Months+
    0 Quote 7Floor
    3 threads on this topic in this forum, many users have the same issue. Technical support take their time to respond. You guys are doing all ok, so dont get flustrated! Lets push for a solution , 70MAI COME ON ! GET ORGANIZED!
    2 Months+
  • 0 Quote 8Floor
    Everything works as it should, you just need to format the card correctly (you can choose another one) https://na-bbs.70mai.com.cn/?thread-1049.htm
    2 Months+
  • Frank 2 Months+
    0 Quote 9Floor
    Try this:
    https://na-bbs.70mai.com.cn/?thread-1058.htm
    2 Months+
Back
Create New Thread